Service is fully operational. All data related to Form Reports - Summary Report and Photos affected by the incident are successfully synchronized.
Posted Oct 24, 2025 - 11:21 UTC
Update
Service has been restored, and we are focused on bringing all operations fully back online. During this period, you may still notice some delays in data synchronization across Forms Reports, Activity Feed, and Photo Gallery.
We appreciate your patience and understanding as we complete the recovery process.
We’ll continue to share updates on the Repsly Status Page as they become available.
Posted Oct 21, 2025 - 10:33 UTC
Monitoring
Service has been restored, and the Repsly mobile and web applications are functioning normally at this time. The outage was related to a widespread issue with our cloud provider, which has now been mitigated.
Our team is continuing to monitor system performance closely to ensure complete stability.
Posted Oct 21, 2025 - 08:12 UTC
Update
Repsly is a part of a widespread cloud provider outage affecting our service. This service outage may be impacting your ability to use the Repsly mobile and web app. Our technical team is prioritizing restoration efforts and will provide updates as the situation evolves. We absolutely understand how frustrating this can be, and we apologize for the disruption.
Please continue to visit this page for the latest updates.
Posted Oct 20, 2025 - 16:01 UTC
Update
We are still working with our cloud service provider to resolve the issue.
Together with the previous issue of activities not being synchronized, the Repsly web portal started to be unresponsive during some actions.
We apologize for the inconvenience and disruption.
Posted Oct 20, 2025 - 14:50 UTC
Update
We are continuing to work with our cloud service provider to resolve the issue. Representatives remain in offline mode, and data will sync once the issue is resolved.
Reminder: Please do not delete the mobile app to avoid potential data loss.
Posted Oct 20, 2025 - 13:24 UTC
Update
We are actively working with our cloud service provider to resolve the issue.
All Representatives are safe and currently working in offline mode. Please note that their activities are not syncing at the moment, but will be synchronized automatically once the issue is resolved.
IMPORTANT: Representatives should not delete the mobile application, as this may result in data loss.
Posted Oct 20, 2025 - 11:49 UTC
Identified
We are currently experiencing an issue where activities sent by Representatives are not displaying in the feed. Our team is actively working to resolve the problem as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.